Dažādas piezīmes

Kā uzlikt libtorrent 1.2.19 uz ArchLinux ... un sačakarēt deluge? RSS šim rakstam 
18:34:04 01/07/2023 iesūtījis HELDON - Sadaļa: HELDON
Kā zināms ArchLinux ir gandrīz visas jaunākās softu versijas, kas vispārīgā gadījumā ir super cool, bet ne vienmēr.
Ko darīt, ja vajag uzlikt vecāku versiju, šajā gadījumā libtorrent 1.2.19 ?

No root konta:
1) pacman -S base-devel
^ šis uzliek base-devel paku
2) pacman -R deluge qbittorrent-nox libtorrent-rasterbar
^ aizvācam deluge (2.1.1), qbittorent-nox (4.5.4) un libtorrent-rasterbar (2.0.9)

No juzera konta:
1) mkdir AUR_builds
2) cd AUR_builds
3) git clone https://aur.archlinux.org/libtorrent-rasterbar-1.git
4) curl -L -O https://aur.archlinux.org/cgit/aur.git/snapshot/libtorrent-rasterbar-1.tar.gz
5) tar -xvf libtorrent-rasterbar-1.tar.gz
6) git clone --branch libtorrent-rasterbar-1 --single-branch https://github.com/archlinux/aur.git
7) cd libtorrent-rasterbar-1
8. makepkg

No root konta:
9) pacman -U libtorrent-rasterbar-1-1.2.19-1-x86_64.pkg.tar.zst
10) pacman -S qbittorrent-nox
11) pacman -S deluge

Mēģinot palaist, redzam, ka rāda smuku kļūdu, kuru nepalīdz salabot pat maģiskais ldconfig.
[user@me~]$ qbittorrent-nox --version
qbittorrent-nox: error while loading shared libraries: libtorrent-rasterbar.so.2.0: cannot open shared object file: No such file or directory

Nu labi, kompilējam qbittorrent no sources no juzera konta un viss iet griezdamies.

Vienīgais jāņem vērā šis - ja tiks updeitoti libtorrent dependencies, tad varētu būs apnicīgi pārkompilēt libtorrent katru reizi.

The AUR is unsupported, so any packages you install are your responsibility to update, not pacman's. If packages in the official repositories are updated, you will need to rebuild any AUR packages that depend on those libraries.

Ar deluge gan tā nesanāk, izskatās, ka sākot no deluge 2.0.4 tiek prasīts libtorrent 2.x līdz ar to uzliekot ar pacman atpakaļ deluge nekas nestrādā.

Mēģināju likt deluge 2.0.3 no AUR līdzīgi kā libtorrent, bet tur notiek auto updeits uz 2.1.1 un nekas nepalaižās, jo netiek atrasts libtorrent.

Mēģināju likt no sources, arī nesanāca.

Rezultātā laikam jāliek tomēr atpakaļ libtorrent 2.0.9 ar pacman un tad ies gan qbittorrent 4.5.4, gan deluge 2.1.1.

Citi raksta

Pašlaik nav komentāru

Komentēt...

Šim ierakstam komentēšanas iespēja ir atslēgta!
This item is closed, it's not possible to add new comments!

Šurpu turpu

«« qBittorrent 4.5.4 un libtorrent 1.2.19 Kur ir tuvākais swedbank bankomāts? »»

Locations of visitors to this page